دستورات پرکاربرد سوئیچ سیسکو

دستورات کاربردی سوئیچ سیسکو

در این مقاله آموزشی قصد داریم به برخی از دستورات کاربردی سوئیچ سیسکو  بپردازیم . قبل از پرداختن به دستورات یا command ها در سوئیچ ، به سطوح مختلف رابط کاربری در ios سیسکو میپردازیم .

سطوح کاربری سوئیچ سیسکو ( mode ) 

دستورات یا کامند ها در سیستم عامل سوئیچ ( cisco ios ) نوشته و پردازش میشود . رابط کاربری سوئیچ یا CLI ، از یک ساختار سلسله مراتبی یا hierarchial استفاده میکند . در این ساختار ، برای فعال سازی قابلیتی خاص ، باید به یک مد ( mode ) خاص وارد شد و سپس دستورات را وارد کرد . مثلا برای ست کردن ip روی اینترفیس های سوئیچ باید وارد مود پیکربندی یا ( configuration mode ) شویم . 

کاربرد هر مود ( mode ) کاربری سوئیچ سیسکو : 

 <switch : این مود تنها برای اجرای دستورات محدود و  مانیتورینگ کاربرد دارد . مانند دستورات پرکاربرد show .

 #switch : مود enable برای اجرای دستورات اجرایی و منایتورینگ کاربرد دارد . برای مثال در این مود میتواان محتویات حافظه فلش را پاک کرد.

switch(config) : مود configuration جهت اجرای دستورات پیکربندی کاربرد دارد . برای مثال برای اتصال به سوئیچ سیسکو توسط telnet .

 

تغییر مود (mode) یا سطوح کاربری در سوئیچ سیسکو :

برای تغییر مود در سوئیچ سیسکو به شکل زیر عمل میکنیم. وقتی ios سوئیچ لود میشود و سوئیچ بالا می آید ، دستگاه در مود <switch  قرار دارد. برای رفتن به مود enable ، عبارت en رو تایپ کرده و وارد این مد میشویم که به شکل #switch میباشد . اگر وارد مود پیکربندی یا configuration شویم ، با تایپ عبارت conf t را تایپ کرده و اینتر میکنیم و وادر مود switch(config)  چنانچه نیاز بود از هر مود خارج شده و به mode قبلی بازگردیم ، باید عبارت exit رو تایپ اینتر کنیم . 

 

دستورات کاربردی سوئیچ سیسکو : 

 

لیست دستورات سیسکو :

کامند

عملکرد

enable این دستور ، کاربر را وارد مود Enable میکند . نام دیگر این مود Privilege Mode است .
configure terminal کامند ، وارد شدن به مد پیکربندی سوئیچ سیسکو یا configuration mode.
interface fast ethernet/number وارد مد پیکربندی اینترفیس مورد نظر میشود . برای اینترفیس های fast ethernet.

reload

کامند ری بوت کردن سوئیچ یا روتر سیسکو ، در مد exec mode یا  (<switch).
hostname name دستور تغییر نام سوئیچ سیسکو . با تعیین کردن نام میزبان ، میتوان به سادگی در شبکه محلی  با سوئیچ ارتباط برقرار کرد.  
copy from-location to-location دستور کپی کردن فایل از یک مکان به مکان دیگر در سوئیچ سیسکو . این دستور در مود enable اجرا میشود .
copy running-config startup-config این دستور ، کانفیگ یا پیکربندی فعلی سوئیچ را در حافظه nvram، (پیکربندی راه اندازی) ذخیره میکند . این کامند در مد enable اجرا میشود .
copy startup-config running-config این کامند پیکربندی راه اندازی (در حافظه nvram ) را با ، پیکربندی فعلی در حافظه ram ادغام میکند .

write erase

erase startup-config

دستور پاک کردن کانفیگ سوئیچ سیسکو ( پاک کردن پیکربندی راه اندازی موجود در حافظه nvram).
ip address ip-address mask
دستور تعیین کردن ip و سابنت ماسک .

shutdown

no shutdown

دستور روسن و خاموش کردن پورت یا اینترفیس های سوئیچ سیسکو . این کامند در مود configuration و پس از انتخاب اینترفیس ، قابل اجراست .
ip default-gateway ip_address تعیین defaultgateway در سوئیچ سیسکو 
show running-config دستور نشان دادن کانفیگ فعلی سوئیچ سیسکو ( پیکربندی موجود در حافظه ram ) . قابل اجرا در مود enable.
description name-string دستور قرار دادن توضیحات برای یک اینترفیس سوئیچ . قابل اجرا در مود configuration  .
show running-config interface interface slot/number کامند نمایش پیکربندی در حال اجرا برای یک اینترفیس خاص . قابل اجرا در مد privileged mode .
show ip interface [type number]  نمایش اطلاعات مفید و کاملی ،در مورد پیکربندی و اطلاعات پروتکل های ip های اینترقیس ها . این دستور در مود enable قابل اجراست.
ip name-server serverip-1 serverip-2 دستور تنظیم کردن آِی پی DNS server . قابل اجرا در مد privileged mode.

 

دستورات عیب یابی سوئیچ سیسکو (Troubleshooting) :

 

کامند

عملکرد

ping {hostname | system-address} [source source-address] یکی از دستورات کاربردی سوئیچ سیسکو دستور تست برقراری ارتباط با host و مدت زمان ارسال و دریافت packet ها . قابل اجرا در مد enable
speed {10 | 100 | 1000 | auto} دستور تنطیم سرعت به صورت دستی و یا تعیین کردن به صورت اتوماتیک . قابل اجرا در مود configuration mode یا interface mode

duplex 

{auto | full | half}
دستور تنظیم full- duplex و half –duplex برای هر پورت سوئیچ سیسکو به صورت دستی . و یا تنظیم به صورت اتوماتیک . قابل اجرا در مود configuration mode یا interface mode 

cdp run

no cdp run

فعال یا غیر فعال کردن پروتکل Cisco Discovery Protocol سیسکو . پروتکل cdp برای به اشتراک گذاری اطلاعات دیوایس های سیسکو که به صورت مستقیم به روتر سیسکو متصل هستند کاربرد دارد .دستور cdp در مود configuration mode قابل اجرا است .

show mac address-table

دستور نمایش جدول مک آدرس سوئیچ سیسکو .

show cdp

کامند نشان دادن فعال یا غیر فعال بودن پروتکل cdp .قابل اجرا در مود configuration .
show cdp neighbors[detail] اطلاعات خلاصه در مورد هر دستگاه همسایه متصل به این دستگاه را نشان میدهد. گزینه detail اطلاعات دقیق در مورد هر همسایه را نشان میدهد. 

show interfaces

اطلاعات دقیق در مورد وضعیت اینترفیس یا پورت ، تنظیمات و شمارنده را نمایش می دهد

show interface status

این دستور اطلاعات مربوط به همه اینترفیس ها یا رابط ها را نشان میدهد. قابل اجرا در مود در مد exec mode یا  (<switch) 

show interfaces switchport تنوع زیادی از تنظیمات پیکربندی و وضعیت عملکرد فعلی ، از جمله جزئیات vlan trunking را نمایش می دهد.
show interfaces trunk این دستور،اطلاعات مربوط به ترانک های عملیاتی فعلی و VLAN هایی که توسط آن trunk ها پشتیبانی می شوند را لیست می کند

show vlan

show vlan brief

لیست تمام vlan ها و رابط های اختصاص داده شده به آن vlan را نشان میدهد . این لیست ترانک (trunk) ها را شامل نمی‌شود .
show vtp status این کامند ، وضعیت vtp فعلی ، شامل حالت فعلی (current mode) را لیست میکند .

 

کامندهای کاربردی سوئیچ سیسکو ، دستورات مسیریابی و Vlan  : 

 

ip routenetwork-number network-mask {ip-address | interface} دستور تعیین یک مسیر استاتیک یا static route در جدول مسیریابی یا routing table .
router rip این کامند ، فرایند مسیریابی توسط پروتکل RIP را فعال میکند . 
network ip-address در حالت پیکربندی روتر ( configuration mode ) ، یک شبکه را با یک فرایند مسیریابی RIP مرتبط می کند .
version 2 در حالت پیکربندی روتر ، نرم افزار را فقط برای دریافت و ارسال بسته های RIP نسخه 2 پیکربندی می کند.
no auto-summary خلاصه سازی خودکار یا summarization را غیر فعال میکند . مود پیکربندی روتر 
default-information originate دستور ایجاد یک مسیر پیشفرض یا default route در پروتکل RIP

passive-interface

 interface

کامند ست کردن یک اینترفیس خاص روی حالت RIP غیر فعال یا passive . در حالت غیرفعال RIP ، به روز رسانی مسیریابی RIP توسط اینترفیس مشخص شده پذیرفته می شود ، اما از آن ارسال نمی شود.

show ip rip database این دستور محتویات پایگاه داده پروتکل مسیریابی RIP را نمایش میدهد .

ip nat 

[inside | outside]

دستور NAT در سیسکو . پارامتر Inside و outside مسیری را که باید عمل ترجمه انجام شود را نشان میدهد .

ip nat inside source 

{list{access-list-number | access-list-name}} interface type number[overload]
یک دستور برای ایجاد ترجمه منبع پویا. استفاده از کلمه کلیدی “list” به شما این امکان را می دهد که از ACL برای شناسایی ترافیکی که تحت NAT قرار دارد استفاده کنید. گزینه “اضافه بار” یا “overload” روتر را قادر می سازد از یک آدرس جهانی برای بسیاری از آدرس های محلی استفاده کند.
ip nat inside source static local-ip global-ip یک دستور حالت پیکربندی برای ایجاد یک ترجمه ثابت بین یک آدرس محلی داخلی و یک آدرس سراسری داخلی

vlan

دستور ایجاد یک VLAN ، و برای جزئیات بیستر وارد مود پیکربندی VLAN میشود .

switchport access vlan از این دستور برای اختصاص یک پورت یا محدوده ای از پورت ها به به پورت های دسترسی یا access استفاده میشود.
switchport trunk encapsulation dot1q دستور تنظیم مود ترانک روی استاندارد dot1q یا 802.1Q .
switchport access پورت مورد نظر را به پورت دستری یا access تبدیل میکند .
vlan vlan-id [name vlan-name] دستور انتخاب نام برای vlan .( نام باید بین 1 تا 32 کارکتر باشد)
switchport mode { access | trunk }

یکی از دستورات کاربردی سوئیچ سیسکو ، کامند مشخص کردن حالت پورت های عضو vlan است  . ( اکسس یا ترانک بودن ).

access : پورت دسترسی بدون قید و شرط تنظیم شده است و به عنوان یک رابط VLAN بدون ترانکینگ عمل می کند که فریم های بدون کپسوله (بدون برچسب) را ارسال و دریافت می کند. یک پورت دسترسی را می توان فقط به یک VLAN اختصاص داد.

trunk : پورت trunk فریم های کپسوله شده (برچسب گذاری شده) را که VLAN مبدا را مشخص می کند ، ارسال و دریافت می کند. ترانک یک پیوند نقطه به نقطه بین دو سوئیچ یا بین سوئیچ و روتر است.

switchport trunk {encapsulation { dot1q } هنگامی که پورت در حالت trunking است ، ویژگی های ترانک را تنظیم می کند .در این حالت ، سوئیچ از ترافیک همزمان و برچسب گذاری نشده بر روی یک پورت پشتیبانی می کند.
encapsulation dot1q vlan-id یک دستور حالت پیکربندی که معیارهای مطابقت را برای ترسیم فریم های 802.1Q در یک رابط به نمونه سرویس مناسب تعریف می کند.


  دستورات DHCP در سوئیچ سیسکو :

 

کامند

عملکرد

ip address dhcp دستور به دست آوردن ip اینترفیس از طریق dhcp در سوئیچ سیسکو . قابل اجرا در مود پیکربندی.
ip dhcp pool name دستور پیکربندی آدرس استخر dhcp در یک dhcp server و ورود به حالت پیکربندی DHCP pool.
domain-name domain دستور تعیین نام برای کلاینت dhcp در سوئیچ سیسکو
network network-number [mask] در حالت پیکربندی DHCP pool برای پیکربندی شماره شبکه و ماسک برای زیر شبکه اصلی یا ثانویه استخر آدرس DHCP در سرور Cisco IOS DHCP استفاده می شود.
ip dhcp excluded-address ip-address [last-ip-address] یک دستور حالت پیکربندی برای تعیین آدرس های IP که سرور DHCP نباید به سرویس گیرندگان DHCP اختصاص دهد.
ip helper-address address یک فرمان حالت پیکربندی رابط برای فعال کردن انتقال و برودکست UDP ، از جمله BOOTP ، دریافت شده در یک اینترفیس.
default-router address[address2 … address8] دستور ایجاد مسیر پیش فرض.
Call Now Buttonتماس با ما
محصول با موفقیت به سبد خرید اضافه شد.
× سوالی دارید ؟